본문으로 바로가기

Rust 보안 업데이트 권고

category 보안이슈/보안공지 2022. 1. 28. 15:16

Rust 보안 업데이트 권고



□ 개요
o Rust 재단은 Rust 프로그래밍 언어에서 발생하는 보안 취약점에 대한 보안 업데이트 공개 [1]
  ※ Rust : 모질라에서 개발한 프로그래밍 언어
o 공격자는 해당 취약점을 이용하여 파일 삭제 등의 피해를 발생시킬 수 있으므로, 최신 버전으로 업데이트 권고
 
□ 설명
o Rust std::fs::remove_dir_all 표준 라이브러리 함수가 레이스 컨디션에 취약하여 발생하는 취약점(CVE-2022-21658)

□ 영향 받는 버전
o Rust 1.0.0 ~ 1.58.0

□ 해결 방안
o Rust 1.58.1
- 제조사의 업데이트 방법 참고 [1]
 

[참고사이트]
[1] https://blog.rust-lang.org/2022/01/20/Rust-1.58.1.html
[2] https://www.rust-lang.org/

 

 

영화는 넷플릭스, 음악은 멜론, 컴퓨터에는 이지클린이 있습니다.

 

이지클린(EzClean) 설치파일 다운받기

 

 

반응형

댓글을 달아 주세요